DPD UK is experiencing label generation issues

Incident Report for Whatnot

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 15:57 PDT

Investigating

We are experiencing intermittent issues generating labels with DPD UK and are actively investigating. Please try again soon.
Posted Jul 08, 2026 - 11:14 PDT
This incident affected: Ship.