[Investigating] Multiple Services

Incident Report for Whatnot

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 03:22 PST

Investigating

We are aware of an issue affecting european users adding PayPal payment methods
Posted Feb 17, 2025 - 01:42 PST
This incident affected: Purchase.