Intermittent European payment processing issues

Incident Report for Whatnot

Resolved

Between 11:30 - 13:41 UTC there was a disruption with the iDEAL payment method causing increased error rates for iDEAL transactions. The issue was external to Stripe and is now resolved.
Posted Aug 20, 2025 - 08:03 PDT

Investigating

We are currently investigating this issue.
Posted Aug 20, 2025 - 07:01 PDT
This incident affected: Purchase.