Label Generation failures for DPD UK

Incident Report for Whatnot

Resolved

The incident has been resolved. UK-based sellers should be able to generate labels normally.
Posted Sep 22, 2025 - 11:27 PDT

Investigating

Our DPD UK shipping label provider is having issues with generating labels at this time. We're aware of the situation and working with them on resolution. During this time UK-based sellers may be unable to generate labels for certain packages
Posted Sep 22, 2025 - 08:37 PDT
This incident affected: Ship.