[Investigating] Mondial Relay shipments causing payout delays

Incident Report for Whatnot

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2025 - 13:13 PDT

Investigating

We are aware of an issue impacting some French sellers' ability to be paid out for orders shipped via Mondial Relay.

Nous sommes conscients d'un problème impactant la capacité de certains vendeurs français à être payés pour les commandes expédiées via Mondial Relay.
Posted Jun 24, 2025 - 08:16 PDT
This incident affects: Ship.