Mondial Relay

Incident Report for Whatnot

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 12:21 PST

Monitoring

We have fixed the issue impacting Mondial Relay labels and are monitoring the results
Posted Dec 10, 2025 - 09:18 PST

Identified

We’re aware of an issue preventing sellers in France from generating labels for Mondial Relay.
Posted Dec 10, 2025 - 07:16 PST
This incident affected: Ship.