DPD UK Maintenance Window 07/05 5 PM - 5:30 PM BST

Incident Report for Whatnot

Resolved

This incident has been resolved.
Posted Jul 05, 2025 - 09:34 PDT

Identified

DPD UK has a scheduled maintenance window from 5 PM BST to 5:30 PM BST on July 5th. During this time label generation functionality may be degraded for some shipments originating in the UK. After this time we anticipate that normal service will resume.
Posted Jul 05, 2025 - 07:02 PDT
This incident affected: Ship.