DHL is experiencing label generation errors

Incident Report for Whatnot

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 12:43 PDT

Investigating

DHL is experiencing label generation errors. Our team is checking with our providers.
Posted Sep 04, 2026 - 11:49 PDT
This incident affected: Ship.