DPD UK Maintenance Window 06/28 5 PM - 6:15 PM BST

Incident Report for Whatnot

Resolved

The DPD UK maintenance window has ended, and label generation functionality should be fully restored for UK sellers.
Posted Jun 28, 2025 - 10:58 PDT

Identified

DPD UK has a scheduled maintenance window from 5 PM BST to 6:15 PM BST on June 28th. During this time label generation functionality may be degraded for some shipments originating in the UK. After this time we anticipate that normal service will resume.
Posted Jun 28, 2025 - 07:58 PDT
This incident affected: Ship.